[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: basic help for bare-boned newbie

From: Peter Jay Salzman
Subject: Re: basic help for bare-boned newbie
Date: Thu, 24 Oct 2002 09:39:08 -0700
User-agent: Mutt/1.4i

hi akim,

first, thank you for responding!

i finally did find out what was wrong: autoconf 2.5x and 2.13 debian
packages were both installed on my system.  the *packages* don't
conflict but the programs do.  inadvertantly, some of what i did used
the 2.5 tools and some used the 2.13 tools.

i made sure to use only the 2.5x tools, and lo and behold it worked.  a
configure script was generated and it almost ran to completion.

   checking whether gcc accepts -g... yes
   checking for gcc option to accept ANSI C... none needed
   configure: error: cannot find install-sh or in . ./.. ./../..

/usr/bin/install is on my system, and is also in my PATH.  but according
to the autoconf info page:


     Set output variable `INSTALL' to the path of a BSD compatible
     `install' program, if one is found in the current `PATH'.
     Otherwise, set `INSTALL' to `DIR/install-sh -c', checking the
     directories specified to `AC_CONFIG_AUX_DIR'

the info page also says that AC_PROG_INSTALL filters out "install"
implementations that are known to be buggy, but i doubt GNU install is

i was able to get configure to complete successfully by commenting out
AC_PROG_INSTALL in, but that's a bandaid fix.   how can i
get configure to recognize /usr/bin/install?


begin Akim Demaille <address@hidden> 
> | hi all,
> | i'm trying to learn autoconf by converting one of my programs to use
> | autoconf.  i'm having difficulty; here's what i tried:
> | 
> |    % cp Makefile Makefile.orig
> |    % mv Makefile
> |    % autoscan
> |    % mv configure.scan   
> |    % autoheader
> |    % autoconf
> |    autoconf: Undefined macros:
> |
> |
> |[Makefile])
> |[xpose.c])
> |    address@hidden ./configure
> |    configure: error: can not find sources in . or ..
> | 
> | the tutorial i'm using claimed that this should've worked.  clearly
> | autoconf _should_ know macro functions like AC_FUNC_MALLOC, so i must be
> | missing a very basic and obvious step.
> How bizarre...  How about giving the version number?  Of autoscan and
> autoconf.
> | can someone tell me what i'm doing wrong?
> | 
> | thanks!
> | pete

Fingerprint: B9F1 6CF3 47C4 7CD8 D33E 70A9 A3B9 1945 67EA 951D

reply via email to

[Prev in Thread] Current Thread [Next in Thread]