[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: trying to install docs that are distributed with my package...

From: Ralf Wildenhues
Subject: Re: trying to install docs that are distributed with my package...
Date: Tue, 29 Aug 2006 10:44:22 +0200
User-agent: Mutt/1.5.12 (2006-08-10)

Hello Ed,

* Ed Hartnett wrote on Tue, Aug 29, 2006 at 01:20:36AM CEST:
> # Get lists of the corresponding ps, info, and pdf files.
> ps_docs = ${} 
> pdf_docs = ${info_TEXINFOS:.texi=.pdf}
> info_docs= ${}
> txt_docs= ${info_TEXINFOS:.texi=.txt}
> # These files will be included with the dist.
> EXTRA_DIST = $(ps_docs) $(pdf_docs) $(txt_docs) $(info_docs)
> This works well. The documents are all build on the developer machine
> when "make dist" is run, and they all appear in the distribution as
> built documentation. When I run "make all" on the distribution,
> nothing happens with these documents. (I am using no-installinfo as an
> automake option).

BTW, why do you choose to not install the info documentation where the
other info documentation ends up in?

> docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
> doc_DATA = $(ps_docs) $(pdf_docs) $(txt_docs) $(info_docs)
> But this now causes the postscript, PDF, text, and info files to be
> built when I run "make install" on the distribution. In other words,
> it doesn't try to install the files I've already included in the
> distribution, it rebuilds them all. I don't want it to rebuild the
> files, just to install the ones I've already shipped.

With PS this is reasonable: the .dvi file is not in the distribution,
so the make rules try to update that.  (Portable make syntax is not able
to express this kind of intermediate dependency.)  Solution is to put
netcdf.dvi in EXTRA_DIST as well.

Which `make' implementation tries to rebuild the other files as well?
On which system?  Do you use a VPATH build?  Do you have overridden the
rules for (some of) these targets, or are the ones issued by Automake
for PDF, PS etc.  used?  If the latter, why doesn't `missing' kick in
and result in a successful build even without `makeinfo'?  Can you try
to get debugging output of the make run to see why else it may think
the targets may be outdated?

Best is a small reproducible example.  Which Automake version BTW?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]