[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Cannot see CFLAGS

From: Hongliang Wang
Subject: RE: Cannot see CFLAGS
Date: Tue, 23 Oct 2007 07:14:52 +0000

> Date: Mon, 22 Oct 2007 16:00:58 -0700
> From: address@hidden
> To: address@hidden
> CC: address@hidden
> Subject: Re: Cannot see CFLAGS
> Hongliang Wang wrote:
>> zizzy_LDADD = ../gen/libzizzy.a ../ora/libzizora.a
>> zizzy_CFLAGS = -Wall -Werror `pkg-config --cflags glib-2.0`
>> zizzy_LDFLAGS = -ggdb `pkg-config --libs glib-2.0`
> -lfoo (which is likely the result of `pkg-config --libs ...`) does not
> go in LDFLAGS. You should put that in LIBS or LIBADD. That is causing
> the order of the command line to be wrong, which causes the link to
> fail.
Thanks for the reply.

I tried to update the according to your advice, but failed. in jz/util
bin_PROGRAMS = zizzy

zizzy_SOURCES = main.c dictionary.c dictionary.h dump.c dump.h zop.c zop.h 

zizzy_LDADD = ../gen/libzizzy.a ../ora/libzizora.a
zizzy_CFLAGS = -Wall -Werror `pkg-config --cflags glib-2.0`
#zizzy_LDFLAGS = -ggdb `pkg-config --libs glib-2.0`
zizzy_LIBADD = -ggdb `pkg-config --libs glib-2.0`


Then I tried to apply the changes:

address@hidden> pwd
address@hidden> automake
util/ use `zizzy_LDADD', not `zizzy_LIBADD'

What should I do then?
Discover the new Windows Vista

reply via email to

[Prev in Thread] Current Thread [Next in Thread]