[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [RFC] Docs: document silent make rules in a new chapter (was: Re: AM

From: Stefano Lattarini
Subject: Re: [RFC] Docs: document silent make rules in a new chapter (was: Re: AM_V_GEN - better docs)
Date: Thu, 18 Nov 2010 21:22:48 +0100
User-agent: KMail/1.13.3 (Linux/2.6.30-2-686; KDE/4.4.4; i686; ; )

On Thursday 18 November 2010, Nick Bowler wrote:
> On 2010-11-18 20:31 +0100, Stefano Lattarini wrote:
> > I have a first, very rough draft of the patch (see attachement); it is
> > nowhere complete, but I'd like to ear from you anyway for early criticism,
> > suggestions, and maybe contributions ;-)
> [...]
> > address@hidden @code{AM_V_GEN}
> > address@hidden FIXME: wouldn't $(AM_V_SILENT) be clearer?  Should we 
> > deprecate
> > address@hidden $(AM_V_at)?  It should be kept for backward-compatibility, of
> > address@hidden course.
> AM_V_GEN is a long enough name as it is; AM_V_SILENT would be even worse
> in this regard.
> AM_V_at is very useful for targets which have multiple commands.  It's
> not that interesting to see "GEN" five times in a row.
There's probably a misunderstanding here; I was suggesting to rename
`AM_V_at' to `AM_V_SILENT', for clarity; and deprecate *only* the old
name `AM_V_at'.  Does my proposal make sense now?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]