[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "rm -f core" in configure

From: Diego Elio Pettenò
Subject: Re: "rm -f core" in configure
Date: Wed, 11 Jul 2012 10:50:11 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120606 Thunderbird/13.0

Il 10/07/2012 23:32, Kenny Ho ha scritto:
> I am trying to convert one of my existing project to use automake but
> after I run autoreconf and tried ./configure, I an "rm: cannot remove
> `core': Is a directory" error.  So I look into ./configure and found
> "rm -f core" in the script.  Now my project actually has a directory
> name "core" but I don't think that rm command is related to my
> source.  Is the "core" directory reserved for use with automake?  Is
> there a way to work around this?

"core" is the default name of the files created by Linux and other
Unices containing the memory dump of a process that crashed. I guess the
reason why there's that `rm` in there is because a number of autoconf
tests do segfault, and in the case the user has a shell session with an
unlimited core size, it would find these extraneous files.

Diego Elio Pettenò — Flameeyes
address@hidden —

reply via email to

[Prev in Thread] Current Thread [Next in Thread]