[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

question about an issue with automake from a brand new user regarding "t

From: Eric Goff
Subject: question about an issue with automake from a brand new user regarding "tool_oldlib"
Date: Tue, 2 Aug 2016 17:07:48 +0000

I have an existing project that appeared to work in the past on slackware.
I am trying to compile it on a modern Ubuntu system:

address@hidden:~/Perforce/bpsmain/main/tests/libdnet$ uname -a
Linux ubuntu 3.19.0-64-generic #72~14.04.1-Ubuntu SMP Fri Jun 24 17:59:48 UTC 
2016 x86_64 x86_64 x86_64 GNU/Linux

address@hidden:~/Perforce/bpsmain/main/tests/libdnet$ autoreconf --version
autoreconf (GNU Autoconf) 2.69

When I run:

I get various warnings.
And eventually it produces "configure" with this line:
old_archive_cmds="$old_archive_cmds~\$RANLIB \$tool_oldlib"

When I eventually run:
./configure --prefix=/tmp/foo

It produces "libtool" that never sets "$tool_oldlib"

And therefore fails when I run my make
ar cru .libs/libdnet.a  addr-util.o addr.o blob.o bufqueue.o ethring.o fifo.o 
hex.o ip-util.o ip6.o ipspace.o mempool.o rand.o session.o shm.o strlcat.o 
strlcpy.o arp-ioctl.o eth-linux.o fw-none.o intf.o ip.o route-linux.o 
Usage: ranlib [options] archive
Generate an index to speed access to archives
The options are:
  @<file>                      Read options from <file>
  --plugin <name>              Load the specified plugin
  -D                           Use zero for symbol map timestamp
  -U                           Use actual symbol map timestamp (default)
  -t                           Update the archive's symbol map timestamp
  -h --help                    Print this help message
  -v --version                 Print version information
ranlib: supported targets: elf64-x86-64 elf32-i386 elf32-x86-64 
a.out-i386-linux pei-i386 pei-x86-64 elf64-l1om elf64-k1om elf64-little 
elf64-big elf32-little elf32-big pe-x86-64 pe-i386 plugin srec symbolsrec 
verilog tekhex binary ihex
make[1]: *** [] Error 1
make[1]: Target `install' not remade because of errors.

The line in libtool looks like this:

Any ideas?

Thank you,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]