[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: t/ at installcheck and AUTOMAKE_UNINSTALLED

From: Jim Meyering
Subject: Re: t/ at installcheck and AUTOMAKE_UNINSTALLED
Date: Mon, 3 Feb 2020 20:37:02 -0800

On Mon, Feb 3, 2020 at 6:23 PM Karl Berry <address@hidden> wrote:
> The test fails at the make installcheck step of
> make distcheck (it succeeds in the normal make check, and it succeeds at
> the make check of make distcheck; only fails in the make installcheck).
> This is because AUTOMAKE_UNINSTALLED is (correctly) set in the
> environment at that point, which causes aclocal-1.16 --print-ac-dir
> to forcibly return the empty string, which does not match the expected
> acdir string:
>   + aclocal-1.16 -Werror --print-ac-dir
>   test "$($ACLOCAL --print-ac-dir)" = "$am_system_acdir"
>   ++ aclocal-1.16 -Werror --print-ac-dir
>   + test '' = /u/karl/gnu/src/akarl/automake-1.16a/_inst/share/aclocal
>   am_exit_trap $?
>   + am_exit_trap 1
> Per this bit in the aclocal-1.16 Perl script:
>   if (exists $ENV{"AUTOMAKE_UNINSTALLED"})
>     {
>       @automake_includes = ();
>       @system_includes = ();
>     }
> (The --print-ac-dir option simply prints the value of @system_includes.)
> So, if I unset AUTOMAKE_UNINSTALLED in the test, it works:
> test "$am_running_installcheck" = yes && unset AUTOMAKE_UNINSTALLED || :
> Since this test is intended to check exactly a value that only is set
> normally in an installation, that seems like a reasonable thing to do.

That sounds eminently reasonable.

I don't recall ever knowing about this AUTOMAKE_UNINSTALLED envvar, so
you are now the sole active contributor who has plumbed those depths

> But I am not sure. Jim, anyone with more experience, can you confirm/deny?
> Thanks,
> Karl
> P.S. This also fails for me if I run make installcheck after
> building the released automake-1.16.
> P.P.S. There are two other tests, print-libdir and aclocal-print-acdir,
> which also fail at the make installcheck step of make distcheck, and not
> sooner. Unfortunately they are not solved by unsetting
> AUTOMAKE_UNINSTALLED, though I think the problem is generally similar.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]