[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] GCC compile problems

From: Michel Catudal
Subject: [avr-gcc-list] GCC compile problems
Date: Sun, 25 Feb 2001 22:38:10 -0500

I tried to compile gcc-20010205 and I get several errors.
I installed avr-binutils-010225 , I've tried previous
versions down to avr-binutils-010109 with identical results.
After looking into the source of the binutils it seems
to me that movw is not defined at all for the avr.

Before making any changes to 
I had a lot of error messages about invalid registers so I
changed in the following code a 0 to r0 and a 1 to r1
Then I had an error about a double definition of processor avr3 in
a temporary .s file. I commented the .arch line and the messages
went away. Now I get an error message telling me that movw is
not defined which seems to be correct as I can't find it in the
binutils. Is there anyone who has a working binutils source tree that would work
with the latest gcc? Obviously that code must have compiled correctly
at one time or another somewhere. I do not wish to ignore the error
messages considering that the code not generated is some code I want.

asm_file_start (file)
     FILE *file;
  output_file_directive (file, main_input_filename);
//  fprintf (file, "\t.arch %s\n", avr_mcu_name);
  fputs ("__SREG__ = 0x3f\n"
         "__SP_H__ = 0x3e\n"
         "__SP_L__ = 0x3d\n", file);
  fputs ("__tmp_reg__ = r0\n"   <---- Here it was 0 instead of r0
         "__zero_reg__ = r1\n"  <---- Here it was 1 instead of r1
         "_PC_ = 2\n", file);
  commands_in_file = 0;
  commands_in_prologues = 0;
  commands_in_epilogues = 0;

Tired of Microsoft's rebootive multitasking?
then it's time to upgrade to Linux.
We have all kinds of links
and many SuSE 7.0 Linux RPM packages

reply via email to

[Prev in Thread] Current Thread [Next in Thread]