[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] Problems compiling GCC under RH7.1

From: MWP
Subject: [avr-gcc-list] Problems compiling GCC under RH7.1
Date: Wed, 27 Jun 2001 01:49:48 +1000 (EST)

Hi ppl...

Ive just moved up to RH7.1 (from 6.0) and am now trying to recompile GCC
for the AVR.

Ive tried absolutly everything i can think of and i still get this error
during compiling of GCC:

-B/home/backup/linux/gcc-stuff/gcc-20010604/gcc/ -B/usr/local/avr/avr/bin/
-B/usr/local/avr/avr/lib/ -isystem /usr/local/avr/avr/include -O2
-DCROSS_COMPILE -DIN_GCC    -W -Wall -Wwrite-strings -Wstrict-prototypes
-Wmissing-prototypes -isystem ./include  -DDF=SF -Dinhibit_libc
-mcall-prologues -g1  -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED -Dinhibit_libc
-I. -I. -I. -I./. -I./config -I./../include  -DL_muldi3 -c ./libgcc2.c -o
/tmp/ccUenhnh.s: Assembler messages:
/tmp/ccUenhnh.s:157: Error: register required
/tmp/ccUenhnh.s:158: Error: register required
make[2]: *** [libgcc/./_muldi3.o] Error 1
make[2]: Leaving directory `/home/backup/linux/gcc-stuff/gcc-20010604/gcc'
make[1]: *** [stmp-multilib] Error 2
make[1]: Leaving directory `/home/backup/linux/gcc-stuff/gcc-20010604/gcc'
make: *** [all-gcc] Error 2

As you can see thats with a snapshot of GCC from 20010604.
But strangly this same version compiled perfectly on my RH6.0 install.

I have also tried compiling the release version of GCC3.0 which gives
EXACTLY the same error messages during compiling.

BTW... im using binutils-2.10.1 compiled for the host and for AVR.

Any ideas?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]