[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] Problems with GCC3.0 + Binutils 2.11.2 + avr-libc-2001071

From: Mike Dombrowski
Subject: [avr-gcc-list] Problems with GCC3.0 + Binutils 2.11.2 + avr-libc-20010717 + BeOS 5.0
Date: Thu, 09 Aug 2001 17:53:31 EDT

Hello all. I have tried to get GCC 3.0 setup as a cross-compiler for 
AVR on my BeOS 5 machine and even though everything compiles and 
installs fine I still run into issues along the lines of "it doesn't 
work" When I try to compile a file containing just "int main( void ) 
{}" with "avr-gcc -mmcu=at90s8515 main.c" I get the error "avr-gcc: 
installation problem, cannot exec `/boot/develop/tools/gnupro/lib/gcc-
lib/avr/3.0/../../../../avr/bin/ld': Missing library" I'm a gcc/avr/
porting newbie and I have no idea what could be causing this error. Any 
other files I try give the same error. Build info at the end.


I followed: http://www.objsw.com/CrossGCC/FAQ-4.html for the general 
form of how to build the cross-compiler. My actually build/configure 
commands were as follows:

For all:
$ target=avr
$ prefix=/boot/develop/tools/gnupro 

$ ../binutils-2.11.2/configure --target=$target --prefix=$prefix -v
$ make all
$ make install

$ ../gcc-3.0/configure --target=$target --prefix=$prefix -v --enable-
$ make all
$ make install

$ make prefix=/boot/develop/tools/gnupro
$ make prefix=/boot/develop/tools/gnupro install                                

reply via email to

[Prev in Thread] Current Thread [Next in Thread]