[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] gdb 5.0 not building, avrsim looking for micro asm?

From: Jason Kyle
Subject: Re: [avr-gcc-list] gdb 5.0 not building, avrsim looking for micro asm?
Date: Fri, 19 Oct 2001 13:06:37 +1300

At 09:29 18/10/2001 -0700, ken restivo wrote
Hash: SHA1

two questions, if i may.

1) avrsim regularly complains about "File is not standard Micro Asm Output File" how can i generate such a beast? i looked in docs for avr-ld and avr-objcopy and found no mention of a Micro Asm format. i have tried binary and a few other formats, avrsim is still not happy.

Not sure which simulator you are trying to use, Micro Asm format is what AVA (http://medo.fov.uni-mb.si/mapp/uTools/index.html) produces and it was replaced by the gnu assembler in binutils a long time ago. There is some work going on at the moment to get a simulator working with gdb-5.0, it will be some weeks/months yet I think.

2) i have been trying to build gdb 5.0 with the  gdb-5.0-avr-patch-0.0.gz.
./configure --target=avr fails:
        linking ./config/i386/xm-linux.h to xm.h
         to tm.h./config/avr/tm-avr.h
        : File not found: ./config/avr/tm-avr.h
        Configure in /usr/src/gdb-5.0/gdb failed, exiting.

        sure enough, config/avr is empty. wha?

the patch applied with no errors, too.

i am obviously missing a step somewhere in the build. any help would be appreciated.

Grab patch-0.1 from http://avr.jpk.co.nz/gdb-5.0-avr-patch-0.1.gz which has proper unix formatting, slight cockup in patch-0.0 thanks to those wonderful CR's in dos/win.


Jason Kyle

PS your email arrived as an attachment .pgp file, would be better to send plain text to the list.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]