[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] Pre-initlized strings only holding two characters

From: Colin O'Flynn
Subject: Re: [avr-gcc-list] Pre-initlized strings only holding two characters
Date: Sun, 16 Mar 2003 06:06:12 -0800 (PST)


Well I figured out the problem, and got it working

I was using an AtMega128 with a JTAG ICE. Rather than
program it directly, I was just using the JTAG ICE +
AVR Studio in emulation mode, and I assumed that
running it like that (especially when I just hit 'run'
and don't single-step it) would be exactly the same as
just loading the .hex file into the AVR.

Did I learn a lesson today... 

It worked perfect when I just programmed the .hex file
in, but didn't work using AVR Studio, so I guess it
was a problem in objtool / AVR Studio...

So from now on its GDB for me ;-)



--- Volkmar Dierkes <address@hidden> wrote:
> Hi Colin,
e GDB> On Sat, 15 Mar 2003 16:03:47 -0800 (PST), Colin
> O'Flynn wrote:
> > char test[10] = "Atmel";
> >
> > The VFD display only shows At
> I tried to verified it here but I get the complete
> string. I am not 
> sure why it happend in your configuration, but it
> seems more a local 
> than a WinAVR(march) problem.
> Volkmar
> _______________________________________________
> avr-gcc-list mailing list
> address@hidden
> http://www.avr1.org/mailman/listinfo/avr-gcc-list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]