[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] ATmega8 & avr-libc

From: Mattias Svensson
Subject: Re: [avr-gcc-list] ATmega8 & avr-libc
Date: Wed, 10 Sep 2003 19:54:55 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010726 Netscape6/6.1

I had the same problem, with avr-libc-20030422cvs though.

The thing was that in the main Makefile and the Makefile in the crt1/ subdirectory of avr-libc the following was missing:

Both the "AVR_CRT_MEGA =" and AVR_CRT_OTHER ="  was empty.

This caused the crtm*.o files not to be built and installed.

It should be:
AVR_CRT_MEGA = crtm161.o crtm162.o crtm163.o crtm169.o crtm323.o crtm128.o crtm8.o crtm16.o crtm32.o crtm64.o

AVR_CRT_OTHER = crt86401.o ctrat94k.o

When I fixed this the crtm*.o files were made and installed ok.

I do not know if this is a general problem or if it was caused by myself somehow, but the fix above made it work for me.

Cheers, Mattias S

Leonard Penzer wrote:


i am not shure, if I am right here, or if this post is OT.

recently I developed successfull with S4433 and S8515. Now I tried to
develop for a ATmega8(L).
But I am getting an errormessage:

bash-2.05b# make
/usr/local/atmel/bin/avr-gcc -g -mmcu=atmega8 -Wall -Wstrict-prototypes
-Os -mcall-prologues -o avrledtest.out -Wl,-Map,avrledtest.map
avrledtest.o -lm
/usr/local/atmel/lib/gcc-lib/avr/3.3.1/../../../../avr/bin/ld: cannot
open crtm8.o: No such file or directory
make: *** [avrledtest.out] Error 1

It seems, that my installation does not feature atmega8. I have poked a
little with configure, but did not managed to enable atmega8 support. It
should be something with tat multisubdir. I have used avr-libc-20020203.
Which version of the avr-libc should I use? A CVS-Snapshot (I've tried
this, but there were different?

Leonard Penzer

avr-gcc-list mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]