[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] WinAVR Issue

From: E . Weddington
Subject: Re: [avr-gcc-list] WinAVR Issue
Date: Thu, 25 Sep 2003 18:42:18 GMT

> Has anyone else seen this problem or has a solution to it?
> I'm trying to make a library in the latest WinAVR 
release.  When I use the
> library, I get this error message:
> could not read symbols: Archive has no index; run ranlib 
to add one
> I ran avr-as  with the -s option.  I even tried ranlib.  
Still no success!
> This used to work on the previous versions of WinAvr.  My 
libraries I
> created with the previous versions also work with this 
> I launched cygwin and ran its "ar" and "ranlib" - same 
error message.
> My current WinAvr is version 20030913.
> Thanks.
> Keith

1. After you run avr-ranlib on your archive, what do you 
get when you run avr-nm -s on your archive?

2. Does adding a verbose option to avr-ar (see manual) tell 
you anything odd?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]