[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] Makefiles WinAVR

From: Amenson Scott (AC/ESC4)
Subject: [avr-gcc-list] Makefiles WinAVR
Date: Fri, 17 Oct 2003 11:04:38 -0500

I am new to the world of avr-gcc and am trying to get a handle on how to use
all of the tools but I am having problems with makefiles.  I am running
WIN2k on my laptop and have installed WINAVR version 20030913.  My interest
in avr-gcc comes from the MSAVR diy-efi project.  I successfully compiled
the code from that project using the included makefile.  Having proven that
the tools seem to be installed properly I tried to go through the simple
exercise in the "Downloading, Installing and Configuring WinAVR".

The program is typed as shown in the document but the directions to modify
the makefile do not match the sample Makefile that came with WinAVR, I
modified it as seemed logical by comparing the variable names between the
directions and the sample makefile.  The top of the makefile is:

PRG            = Test1
OBJ            = 
MCU_TARGET     = at90s2313
OPTIMIZE       = -O2

DEFS           =
LIBS           =  

The source program is "Test1.c" and is in the same directory as my modified
makefile.  When I try to run make from PN I get the following error:

avr-gcc -g -Wall -O2 -mmcu=at90s2313  -Wl,-Map,Test1.map -o Test1.elf  
process_begin: CreateProcess((null), avr-gcc -g -Wall -O2 -mmcu=at90s2313
-Wl,-Map,Test1.map -o Test1.elf, ...) failed.
make (e=2): The system cannot find the file specified. Make: *** [Test1.elf]
Error 2

> Process Exit Code: 2

When I try to run make directly from SH I get:

avr-gcc -g -Wall -02 -mmcu=at90s2313 -Wl, -Map,Test1.map, -o Test1.elf
+0x0): undefined reference to 'main'
c:\WinAVR\utils\bin\make.exe: ***[Test1.elf] Error1

I have also tried to compile some of the Mavric sample files as an exercise
and also have issues.  When I try to compile diag
(http://www.bdmicro.com/code/), as downloaded I get the following error:

C:\DOCUME~1\anc2fh\LOCALS~1\Temp\make25842.sh: awk: command not found
Make: *** [depend] Error 127

> Process Exit Code: 2

What am I doing wrong???

Scott S. Amenson
> Robert Bosch Corporation

reply via email to

[Prev in Thread] Current Thread [Next in Thread]