[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] SBIC PINx, ... won't work

From: tux
Subject: [avr-gcc-list] SBIC PINx, ... won't work
Date: 25 Dec 2003 17:46:11 -0000


I'm trying to compile an asm routine for usb data transfer with FTDI's
FT245BM. It worked ok for the at90s2313 and an old avr-gcc but when I
tried to compile it for atmega162 it didn't find crtm162.o, so I updated
It seems to find the file now but whatever mmcu I use, it results in an
error for commands like this:



usb.asm:12:1: warning: no newline at end of file
usb.asm: Assembler messages:
usb.asm:8: Error: number must be less than 32

First of all, there's definetly a new line at the end of my file.
If it was just that, it wouldn't be a problem for me at all.
But it won't compile because of line 8, and line 8 is the above
mentioned "sbic PIND, USB_RXF".

What's wrong with it? I use the following the command to compile my file:

avr-gcc -c -Wa,-gstabs -x assembler-with-cpp -mmcu=atmega162 usb.asm

If this topic has been discussed before, please point me to the
appropriate websites.

Any help greatly appreciated.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]