[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] jmp boot loader

From: Yannick PODGORSKI
Subject: Re: [avr-gcc-list] jmp boot loader
Date: Mon, 3 Jan 2005 17:24:29 +0100

I try but when I use "rjmp"  :
       -Wl, --defsym=app_start=0 in Makefile
       asm volatile("rjmp app_start"); in code

I try but when I use "rjmp" there is an error :

   bootldr.o(.text+0x280): In function `BootLoader':
/home/avr-boot2/bootldr.c:315: relocation truncated to fit: R_AVR_13_PCREL no symbol
   make: *** [main.elf] Erreur 1

I try with "jmp" and there is no error but the result is the same. The program restart
to boot section and not application section.
Very strange.
Thanks for your answer.


----- Original Message ----- From: "Matthias Weißer" <address@hidden>
To: "Yannick PODGORSKI" <address@hidden>
Sent: Thursday, December 30, 2004 9:42 PM
Subject: Re: [avr-gcc-list] jmp boot loader

Yannick PODGORSKI schrieb:
asm volatile ("jmp 0"); // to start application but It restarts to boot section (not application section).

I had similar problems with a Mega8 bootloader and solved it (with some hints by Joerg Wunsch) this way:

asm volatile("rjmp 0");
asm volatile("rjmp app_start");

and defined a linker symbol "app_start" at the linker command line:

Worked for me.

Matthias Weißer

reply via email to

[Prev in Thread] Current Thread [Next in Thread]