[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] avr-gcc-4.0.0 for Win

From: Jurek Szczesiul
Subject: [avr-gcc-list] avr-gcc-4.0.0 for Win
Date: Sun, 8 May 2005 16:53:13 +0200

Hi !

I've tried to compile 4.0.0 release for Windows but I do 
something wrong - no success. Perhaps someone would
find my mistake ?

1. Cygwin ( updated ) on XP SP2, 
- SP2 firewall OFF
- ZoneAlarm firewall ON
- Norton AV active
2. binutils 2.15 for avr compiled and installed in /avrgcc
without problems
3. /avrgcc/bin added to Cygwin's PATH
4. gcc core unpacked into /inst/gcc-4.0.0
5. compilation made in /inst/gccobjdir
6. configured as :

../gcc-4.0.0/configure \
--target=avr \
--prefix=/avrgcc \
--enable-languages=c \
--disable-nls \

without problems.

7. make all 
- fixincludes - OK
-libiberty - OK

-everything always fails on _muldi3 :

<cygwin's output >
make[1]: Entering directory `/inst/gccobjdir/gcc'
make \
  CFLAGS="-g -O2  -W -Wall -Wwrite-strings -Wstrict-prototypes 
-Wmissing-prototypes   " \
  CONFIG_H="config.h  auto-host.h ../../gcc-4.0.0/gcc/../include/ansidecl.h 
ig/i386/xm-cygwin.h" \
  -f libgcc.mk all
make[2]: Entering directory `/inst/gccobjdir/gcc'
/inst/gccobjdir/gcc/xgcc -B/inst/gccobjdir/gcc/ -B/avrgcc/avr/bin/ 
-B/avrgcc/avr/lib/ -isystem /avrg
cc/avr/include -isystem /avrgcc/avr/sys-include -O2  -DIN_GCC -DCROSS_COMPILE   
-W -Wall -Wwrite-str
ings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition  -isystem 
./include  -DDF=SF -D
inhibit_libc -mcall-prologues -g  -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED 
-Dinhibit_libc -I. -I. -I../
../gcc-4.0.0/gcc -I../../gcc-4.0.0/gcc/. -I../../gcc-4.0.0/gcc/../include 
ibcpp/include  -DL_muldi3 -c ../../gcc-4.0.0/gcc/libgcc2.c -o libgcc/./_muldi3.o
../../gcc-4.0.0/gcc/libgcc2.c:533: internal compiler error: in simplify_subreg, 
at simplify-rtx.c:37
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make[2]: *** [libgcc/./_muldi3.o] Error 1
make[2]: Leaving directory `/inst/gccobjdir/gcc'
make[1]: *** [stmp-multilib] Error 2
make[1]: Leaving directory `/inst/gccobjdir/gcc'
make: *** [all-gcc] Error 2 

The same error appears under MinGW32.

BTW - I compiled previous releases with MinGW
on the same PC many times without errors.

Best regards 
Jurek Szczesiul

reply via email to

[Prev in Thread] Current Thread [Next in Thread]