[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] problems on linux

From: Kitts
Subject: Re: [avr-gcc-list] problems on linux
Date: Tue, 31 May 2005 23:30:52 +0530
User-agent: KMail/1.8

On Tuesday 31 May 2005 11:07 pm IST, you wrote:
> Kitts wrote:
> >Hi All,
> >
> >Does anybody here use FreeRTOS with the AVR?
> >
> >Well! With FreeRTOS, i tried running the demo application making
> >suitable modifications for use with the atmega16 but it was unable
> > to handle the number of tasks. I then reduced the tasks and it
> > worked fine.
> >
> >I did all of the compilation and programming on linux and avrdude
> > with the stk500v2 protocol. I put up the issue with the number of
> > tasks on the FreeRTOS forum and to my surprise, others on the forum
> > were able to run the demo as is with all of the tasks executing!
> On Linux? Or on Windows?

On windows.

> >I then tried compiling for the mega128 and nothing would work! I
> > then thought i needed to debug on a simulator and discovered that
> > "make coff" or "make extcoff" returned errors. Now the interesting
> > part is that all of what i tried work fine when using Winavr on
> > windows.
> The ELF to COFF convertor is only available on WinAVR as it is only
> used by Atmel's AVR Studio which is a Windows-only program. For
> debugging on Linux, use GDB + simulavr.

Oh! i did not know this. How then to use VMLAB which expects coff files? 
Since i was planning to use VMLab. But i guess the code size would be 
greater than VMLAB would permit. I do not know how to use simulavr 
hence i have not tried.

> >Does anybody have a clue of what could be the problem? I seek your
> >advice!
> Not offhand. Probably the FreeRTOS folks would have to take a look at
> what's going on.

I have been in discussion with Richard Barry of FreeRTOS but neither of 
us could figure it out. With him attempting on windows using Winavr he 
said "It seems that although the asm code generated is basically the 
same (labelnames are different so could possibly also have different 
addresses) the debug information format is different.  I can see the 
path names in the .elf file, but trying to open it in the simulator it 
just says "the object code file does not contain source code 
information".  Maybe because the Windows version does not like Linux 
style file paths?  Although it should be able to use either format."

> Also, are you making sure that the version of AVR GCC (and other
> programs) are the same on Linux and Windows?

Yes. We are both using AVR-GCC version 3.4.3 and avr-libc version 1.2.3

reply via email to

[Prev in Thread] Current Thread [Next in Thread]