[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] bootloader not jumping back to app

From: jeffrey traer bernstein
Subject: Re: [avr-gcc-list] bootloader not jumping back to app
Date: Mon, 08 Aug 2005 11:06:06 -0400
User-agent: Mozilla Thunderbird 1.0 (Windows/20041206)

Yeah i did it that way, and tried inline asm but no deal.
Here's the weird thing: then i tried it a little differently and just put my bootloader code in the .bootloader section and moved that to 0x3800 and the put a little LED blinking program in the main. now if the bootloader jumps to the app and runs the blinking app i orginally programmed BUT when i put a new program in the flash with bootloader the bootloader does not exit and the PC just keeps looping in the bootloader for some reason. it seems like maybe there is something in the application section that the bootloader needs or something that is getting overwritten when i program. any ideas?

Joerg Wunsch wrote:

jeffrey traer bernstein <address@hidden> wrote:

Problem is when i try to jump to 0x0000 using a function pointer or
inline assembly the app code i loaded doesn't seem to start.

How do you jump to 0, did you make sure it actually resulted in what
you want?

Here's the AppNote AVR109 way (that is proven to work):

void (*funcptr)( void ) = 0x0000;

If you need a genuine reset (which will also return all IO registers
to their default state), rather use the watchdog.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]