[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] Re: [avr-libc-dev] RFD: more avr-libc API changes

From: Matthew MacClary
Subject: Re: [avr-gcc-list] Re: [avr-libc-dev] RFD: more avr-libc API changes
Date: Thu, 8 Sep 2005 09:26:28 -0700
User-agent: Mutt/1.4.1i

On Wed, Sep 07, 2005 at 11:27:21PM -0600, E. Weddington wrote:
> Joerg Wunsch wrote:
> >. I'd like to get <avr/signal.h> and <avr/interrupt.h> to eventually
> > be merged.  As a next step, we could deprecate one of those, and
> > issue a #warning if it gets included.  But which of the names to
> > retain?  I tend to keep <avr/interrupt.h> as this sounds more
> > logical, but then, interrupt handlers are usually introduced with
> > SIGNAL() for us...
> > 
> I don't have a good answer either. :-/

    My suggestion would be to change INTERRUPT to be the same as
SIGNAL, and then deprecate SIGNAL. After this the <avr/interrupt.h>
file could be used and all naming would be completely obvious.
    Developers that actually need to use INTERRUPT could just use the
new low overhead interrupt routine suggested by James A.R. Koehler:



reply via email to

[Prev in Thread] Current Thread [Next in Thread]