[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] Re: [avr-libc-dev] RFD: more avr-libc API changes

From: Royce Pereira
Subject: Re: [avr-gcc-list] Re: [avr-libc-dev] RFD: more avr-libc API changes
Date: Fri, 09 Sep 2005 10:28:11 +0530
User-agent: Opera M2/8.02 (Win32, build 7680)

On Fri, 09 Sep 2005 01:00:44 +0530, Joerg Wunsch <address@hidden> wrote:

As Zane D. Purvis wrote:

How about changing the name to "ISR," which would do the same thing
as the existing "SIGNAL"?

Then, SIGNAL and INTERRUPT can both be deprecated (avoiding future

It has been suggested before, but so far, nobody else seemed to
care about that suggestion.

In SDCC (mcs51 open source C compiler) one can name their ISR as anything, and then set an attribute to specify it as an ISR for a specific source. Like:

void zerocrossover(void) interrupt EXT0
void check_inputs(void) interrupt TF1

Can this be done with AVR-GCC and what would be the problems implementing this?

Using Opera's revolutionary e-mail client: http://www.opera.com/mail/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]