[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] Re: [avr-libc-dev] RFD: more avr-libc API changes

From: Marek Michalkiewicz
Subject: Re: [avr-gcc-list] Re: [avr-libc-dev] RFD: more avr-libc API changes
Date: Fri, 9 Sep 2005 19:18:16 +0200
User-agent: Mutt/1.5.9i

On Fri, Sep 09, 2005 at 10:35:46AM -0600, E. Weddington wrote:

> - I do like the idea that Royce has (above) about naming the ISR 
> function any name. However, I agree with Joerg, in that it would take an 
> awful lot of effort. Perhaps someday, but not now.

Probably not that awful :) - see how it is done in the msp430 port.

If the API is going to change soon, doing this too at the same time
would be nice.  Unfortunately, we can't follow msp430 exactly, as
their "interrupt" and "signal" attributes have swapped (!) meanings
compared to ours, so we need different names to avoid even more
confusion.  But the basic idea (attribute with numeric argument
specifying the vector to override, or none) looks nice and clean.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]