[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] New install not working

From: wbounce
Subject: [avr-gcc-list] New install not working
Date: Wed, 9 Nov 2005 07:36:13 -0500

On a new laptop windows xp SP2
Installed winavr 20050214 version 3.4.3

Took an existing project that ran under version 3.4.1
And tried to run make all under new install with the same makefile.
I get 
make: ** no rule to make target 'Robot.o', need by Robot.elf stop

I added an additional tool menu option to compile individual files to
assembler code some run some do not.
For instance 
Make Robot.s does not work.
Make FSM.s does not work.
Make i2c.s does work.
Make DoSonar.s does work.

At first I thought it may have been case but DoSonar does work.

I tried to use a new Makefile generated by the Mfile utility but I get
the same results. 
As far as I can tell the makefile only has some new dependencies flags.

I tried running make directly from the dos prompt and adding -p and -d
option and I see it checking a whole lot of extra stuff not related to
the makefile ie .info, .dvi,.web. I by no means claim to be a make
expert so that really did not help.

The demo.c and twi.c examples will compile fine however these are not
multi file projects 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]