[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] avr-objcopy error (no sections to be copied) (was: He

From: Joerg Wunsch
Subject: Re: [avr-gcc-list] avr-objcopy error (no sections to be copied) (was: Help! gcc 4.1.1, dwarf-2 and Atmel USB parts)
Date: Sun, 17 Dec 2006 22:31:51 +0100 (MET)

Rick Mann <address@hidden> wrote:

> So, I tried running the Makefile supplied with the Atmel USB HID
> example, and I get an error I don't know how to interpret.

It's still the same error as in the subject of the thread.

> ../usb_specific_request.c:236:2: warning: #warning with avrgcc
> assumes devices descriptors are stored in the lower 64Kbytes of on-
> chip flash memory

This only means that avr-libc's ..._P() functions never deal with
RAMPZ, so all strings passed to them need to be below 64 KiB.  When
using the standard "progmem" section attributes, the linker script
always place these data at the beginning of the flash, right after the
interrupt vector table but in front of any other executable code.

> change-section-lma .eeprom=0 -O ihex hid_gen.elf hid_gen.eep
> avr-objcopy: there are no sections to be copied!
> avr-objcopy: --change-section-lma .eeprom=0x00000000 never used

This is still the same error as the subject: binutils 2.17 went picky
about attempts to copy over empty sections.  Just don't do it then: if
you don't have any initialized EEPROM data, don't try to copy them.

If you want to "maybe copy them", just prefix the respective
avr-objcopy command in the Makefile with a dash: this will make "make"
ignore the error.

cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL

http://www.sax.de/~joerg/                        NIC: JW11-RIPE
Never trust an operating system you don't have sources for. ;-)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]