[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] Building avrdude on Solaris 10

From: Andreas Höschler
Subject: Re: [avr-gcc-list] Building avrdude on Solaris 10
Date: Thu, 17 Dec 2009 18:12:22 +0100

On Mittwoch, Dez 16, 2009, at 21:16 Europe/Berlin, Joerg Wunsch wrote:

gcc -DHAVE_CONFIG_H -I.  -DCONFIG_DIR=\"/usr/local/etc\"  -Wall -g -O2
-MT libavrdude_a-config_gram.o -MD -MP -MF
.deps/libavrdude_a-config_gram.Tpo -c -o libavrdude_a-config_gram.o
`test -f 'config_gram.c' || echo './'`config_gram.c
mv -f .deps/libavrdude_a-config_gram.Tpo
/bin/bash ./ylwrap lexer.l lex.yy.c lexer.c -- flex
m4: bad option: -P

It seems the lexer wrapper script requires a GNU version of the m4
macro processor.  This one is often called "gm4" (on systems where the
native m4 command is not the GNU one).

What is this "AVRDUDE patch tracker" thing?


In particular, have a look at patch #6866.

I tried the m4 package from sunfreeware. This did not do the trick. I finally built m4 on my own as follows:

        gunzip m4-1.4.13.tar.gz
        tar xvf m4-1.4.13.tar
        cd m4-1.4.13
        make install

This worked an did the trick. I now have


on my Solaris machine!

Thanks a lot,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]