[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] avr-gcc 4.7.2 - compiling problem with attiny4 on debian

From: Felipe Morato
Subject: [avr-gcc-list] avr-gcc 4.7.2 - compiling problem with attiny4 on debian wheezy
Date: Thu, 21 Feb 2013 10:19:55 -0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130107 Thunderbird/17.0.2

Hello guys!

I hope this isn't basic stuff but I have already tried the docs and it
didn't help.

I've got an attiny4 and can't compile the code for it. I'll describe bellow:

My code is simply a blink led for testing it.

If I run "avr-gcc --target-help" the attiny shows up accordingly.
Though when I try to compile the code with "avr-gcc -mmcu=attiny4 -Wall
-Os -std=c99 -c main.c -o main.o"
it complains:
avr-gcc: error: unrecognized argument in option ‘-mmcu=attiny4’
avr-gcc: note: valid arguments to ‘-mmcu=’ are:
[here is a list of all supported ones that doesn't include attiny4,5,9,10]

I have also trying to use "avrtiny10" but it yielded the same.

Can someone help me get that compiled?
I hove i've provided enough info.

I really don't understand if this is a debian problem, if mine mistake
or if it's an avr-gcc one.
Thanks in advance!
Felipe Morato

reply via email to

[Prev in Thread] Current Thread [Next in Thread]