[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug #61169] Bad EEPROM read on mega2560 R3 Arduino board

From: Shane Santner
Subject: Re: [bug #61169] Bad EEPROM read on mega2560 R3 Arduino board
Date: Thu, 16 Sep 2021 11:47:34 -0500

Reads from eeprom and flash take a normal amount of time. Maybe 20s for
flash and a few seconds for eeprom.

I did have to fix the bootloader on the atmega2560 using an arduino uno
board. Maybe I introduced an error in that process (wrong bootloader
uploaded for example).

//------- +*†*+ ------- ȌȔȕȍȕȕȍ

Shane Santner
Founder and President, roundup2roundup
Embedded RE @ blackowl <http://blackowlre.com/>

On Thu, Sep 16, 2021 at 10:27 AM Andy Bennett <andyjpb@ashurst.eu.org>

> Hi,
> > I have a mega2560 R3 arduino board. I created a simple sketch
> > from the Arduino
> > IDE from file->Examples->EEPROM->eeprom_clear and then modified it to
> write
> > 0x00112233445566778899aabbccddeeff repeating to the eeprom memory. After
> > writing out these values and then using avrdude to read them back I get
> > 0x00112233445566770011223344556677 instead. I have a custom programmer
> that
> > read back the expected values correctly.
> >
> > The avrdude command I am using for reading out the eeprom is:
> > avrdude -p atmega2560 -c wiring -P COM4 -b115200 -U eeprom:r:dump.bin
> I had a similar problem reading/writing from/to a Mega2560 R3 Arduino
> board
> with a JTAG3ICE in ISP mode. I managed to read the fuses, flash and eeprom
> but couldn't write them reliably.
> I managed to flash the arduino bootloader reliably and then flashed the
> rest using that.
> The ISP was also very slow, taking ~20 minutes to read or write the image
> from/to flash (which was > 200KiB large).
> I'm not sure if there is a problem with these boards. My searching was
> inconclusive as not many people seem to post about using the ISP header
> and
> lots of people who have this problem solved it by reflashing the
> bootloader.
> I tried powering it through the power jack rather than the USB port but
> that didn't seem to help.
> How long do your EEPROM reads and writes take?
> Best wishes,
> @ndy
> --
> andyjpb@ashurst.eu.org
> http://www.ashurst.eu.org/
> 0x7EBA75FF

reply via email to

[Prev in Thread] Current Thread [Next in Thread]