[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] Re: GCL on Cygwin for Axiom

From: Bill Page
Subject: [Axiom-developer] Re: GCL on Cygwin for Axiom
Date: Wed, 20 Nov 2002 11:40:05 -0500


Damn. I am sorry to hear that Schelter is not still
available. I guess the Internet hasn't quite progressed to
that stage yet... And it's a reminder to me that there is
some urgency in this project to document Axiom and make it
available. <frown>

What I meant to write was GCL (Schelter's lisp), not GCC -
It was late and I was frustrated. I am more awake not.

Yes, GCC runs just fine on Cygwin for me but I do not have
a running version of GCL. In comparison to CCL, GCL is a
monster! Nearly everything I have tried to do in order to
make a running version of GCL under cygwin has failed with
obviously incorrect and untested code C coding. Getting CCL
to run was a piece of cake compared to this!

Does your offer to help extend to GCL? I have so many
problems and have tried so many things that it is a bit
hard to know where to start asking questions. But ...

1) First things: The version 2.4.1 of GCL that is in your
CVS is a bit out of date. The current version is 2.4.3.
And even the version of GMP (GNU math package) that is
in 2.4.3 is quite out of date. The most recent version
of GMP is 4.1

2) Via the web, I found that it is known that version 2.4.1
of GCL is missing some critical files for the Cywin build,
specifically 'unexnt.c'. So after several more failed
attempts witn 2.4.1, I download 2.4.3 and tried to compile
it. unexnt.c is there, but there are a whole host of other
problems, many of which seem to relate to GMP. So I
downloaded 4.1 of GMP. That built just fine on it's own
and after some fiddling I finally got GCL to link with it.
After alot of fixing other small things, I finally got to
the final load step for GCL only to have the the loader
blow up with a segment fault and stack dump ... jeez.

3) There is a "pre-release" version of GCL posted at the
Savannah site which is supposed into compile into native
Window's application with the mingw32 version of GCC.
Perhaps that is where I will try to go next.

4) But first a few more attempts. I am in the middle of
getting the missing unexnt.c file from the newest version
of GCL and using it with the older version. I will let you
know how far this one goes.

Bill Page.

> From: root <address@hidden>
> Date: 2002/11/20 Wed AM 07:15:24 EST
> To: address@hidden
> CC: address@hidden,  address@hidden
> Subject: Re: GCL on Cygwin for Axiom
> Bill,
> Schelter's dead. But if you do get an answer let me know :-)
> Did you want help with GCC (Gnu Compiler Collection) or
> GCL (Gnu Common Lisp)?
> I thought you had GCC running. How can I help?
> Tim

reply via email to

[Prev in Thread] Current Thread [Next in Thread]