[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] RE: TeXmacs / AXIOM under SuSE 8.0

From: Bill Page
Subject: [Axiom-developer] RE: TeXmacs / AXIOM under SuSE 8.0
Date: Sun, 9 Nov 2003 19:45:59 -0500


I am sorry to hear that you are having so much trouble!
I have no experience with SuSE so for now I am at a loss
to help. But as SuSE is apparently quite common in Europe,
surely there are people who successfully run TeXmacs on
this platform. I hope they can help. Perhaps it might be
worth posting a message to


On Sunday, November 09, 2003 6:47 AM you wrote:
> as I promised, I will keep you informed about my quest to
> run AXIOM inside of TeXmacs. I would not yet call it
> nightmare, since it kept me from sleeping last nights...

I know the feeling but I am sure there are better things
to keep you from sleeping at night! <grin>

> ... 
> * Now I downloaded TeXmacs sources and tried to compile...
>   -- The compilation failed to to a missing guile package

This is normal. Yes guile is required. But you should be
careful to note which version of guile that you install.
I have seen reports of TeXmacs errors with some versions
of guile on some systems. I am not sure which version is
best (Joris might tell you.) but probably not the newest

>   -- I downloaded guile and ./configured, make, make
>      install worked, hence I think guile has been installed
>      successfully. I was able to start it, but don't know what
>       to do with it.
>   -- I did a seciond run on TeXmacs and it compiled without
>      further errors.

Good. Did you also to make install? Does TeXmacs startup
normally, building a bunch of fonts etc. Can you display
the help pages?

>   -- I made sure that axiom and AXIOMsys is in the path
>   -- I copied tm_axiom 1.0.3 as distributed from the savannah
>      AXIOM web-site and copied it to the correct places(while
>      the RedHat rpm put TeXmacs in the dirs /usr/share/TeXmacs
>      and /usr/libexec/TeXmacs the compiled version resides in
>      /usr/local/share/TeXmacs and /usr/local/libexec/ which
>      should be no problem.

Correct, it should be no problem.

>   -- to have a reference, I renamed my maple8 (vioa a link) 
>      into maple, so that the command maple launches a maple8
>      command line session.
> * My Findings:
>   -- It is impossible (for me) to detect from inside TeXmacs 
>      which version is running, the rpm is while the
>      self compiles is This is annoying and there should
>      be a possibility to get this inforation in the menu
>       Help->About

I agree. I hope that it is implemented soon.

>   -- After starting (the compiled) TeXmacs, I do no longer find
>      in the Text->Session menu the session called Shell, thats 
>      quite awkward, since a shell is always in the path?

Oh, oh. Something is wrong! You should have Shell and it should
work. If you do not have this, then I think there is still
something wrong with the TeXmacs installation.

>   -- TeXmacs started a scheme session and I could type 
>      something after the prompt, and TeXmacs came up with some
>      scheme output (since I do not know scheme, I produced an
>      error message, but it looks quite functioning.

That is good.

>   -- TeXmacs was able to strt a maple (veriosn8) session, I see
>      the Maple leaf startup message, but then a red written 
>      error message and further input to maple was no possible.

What is the error message?

Please try it with Maple release 5. I.e. Change your symbolic
maple link to maple5. 

>   -- TeXmacs is still not able to start an AXIOM session, the 
>      console says that tm_axiom is loaded (i.e that from savannah
>      AXIOM) but nothing happens, beside that a blue session box
>      is created. Typing in this box is possible but nothing happens
>      after pressing  <return>, I get just a new line. If I goto
>      the Session menue and press close session, I get an axiom
>      promt 'axiom]' but there is no further typing possible.

If a little bit of programming in "C" does not worry you,
you might try to set the debugging option in the tm_axiom.c
file. You will see some comments near the beginning of the
file that tell you how to set the debugging. Edit the tm_axiom.c
file and then re-compile it and copy it where TeXmacs will see
it. Now when you start Axiom a file will be created that shows
the commands that are sent too and from Axiom. Maybe this can
help us to see what is going wrong.

But I am still worried why you do not have a Shell session
option. Something is indeed strange.

> All in all I spent now several hours to check pathes, to move 
> the files to the correct place, compile guile, TeXmacs etc 
> but didn't succed in making TeXmacs even functional with 
> maple (version8) (I didn't check with maple 5,6,7,9, since 
> maple 8 might be still the most common in use and should wotk 
> without problems)

I would hope so but the people who wrote the TeXmacs interface
for Maple do not seem to have had much cooperation from Maplesoft
about solving problems. And we know how hard it can be (sometimes)
to get the information that one needs.

I have heard that there are two different interfaces available
for TeXmacs - Maple, but I am not sure which one is packaged
with TeXmacs. If necessary we can ask Christian EVEN
address@hidden who is the author of these programs.

If/when time permits I still intend to write a version of
tm_maple to work with the new OpenMaple interface, but so
far time does not permit ...

> Given the variouse maple versions, it might be a good habit 
> of TeXmacs to provide tm_maple(version) files if the is a 
> need to have different such interfaces, the same may go for 
> axiom, tm_axiom.gnu1 tm_axiom.NAG etc

As usual there has not been enough work done on this. And
the developer of TeXmacs does not like non-free software.
> I would really like to hear if other have succeded to work 
> with TeXmacs under SuSe, say with maple, maxima, and of 
> course with AXIOM!

I hope also to hear.
> I will ponder further on what I might have done wrong and 
> then give it another chance. For the moment I ran out of 
> further ideas ....

Do you have any opportunity to use another version of
Linux? Perhaps when you see how it works on a platform
that is known to work, it will be easier to see what is
different and what needs to change for SuSE.

Bill Page.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]