[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: address@hidden: Re: [Axiom-developer] Compiling error]

From: C Y
Subject: Re: address@hidden: Re: [Axiom-developer] Compiling error]
Date: Fri, 2 Apr 2004 10:50:48 -0800 (PST)

--- root <address@hidden> wrote:
> Camm,
> CY is building Axiom on a Gentoo system and it fails during the lisp
> compile of the first lisp file.

It's kinda weird Camm - I think at one point I even swapped in a
current cvs tree and tried building that, with the same results.

> We tried running the newly built lisp image directly and the compile
> succeeds so the image seems to be able to run ok.

The failure seems to come after the makedep.lsp is executed - something
being loaded there must cause some kind of instability on my specific
system :-(.

> A couple of notes:
> 1) The build process for axiom at this stage is intending to build
>    an image called "depsys". To do this it creates a lisp file which 
>    contains all of the instructions about how to make depsys:
> (load "/home/user/axiomtoplevel/axiom/obj/linux/interp/makedep.lisp")
> Perhaps you can try to start the lisp image and hand-load this file:
>   /home/user/axiomtoplevel/axiom/obj/linux/bin/lisp
>   > (load
> "/home/user/axiomtoplevel/axiom/obj/linux/interp/makedep.lisp")

That's what I did in my previous example.  Same failure :-(.
> 2) You could try to build a down-level version of lisp and see if
> that succeeds.

>    this will now build a system based on gcl-2.6.1. 
>    Camm has made changes to GCL and they may have affected the build
>    (although this is just superstition at this point but worth
>    trying).
> Tim

OK, I'll give that a shot.  


Do you Yahoo!?
Yahoo! Small Business $15K Web Design Giveaway

reply via email to

[Prev in Thread] Current Thread [Next in Thread]