[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] Re: Hyperlinks

From: root
Subject: [Axiom-developer] Re: Hyperlinks
Date: Tue, 16 Oct 2007 02:12:50 -0400

>> Tim Daly writes:
>> I need to understand this problem and the Suse problem in gcl
>> so I can give Camm some patches.
>> Tim

Arthur Ralfs writes:
>What problem are you having on Suse?  That's what I use.


I've attached some of the correspondence with C. Frangos.

C. Frangos installed Axiom on Suse 10.2 on a 64 bit machine.
It appears that GCL cannot find the GCC compiler even though the
compiler appears to be available and on the path. I built a Suse10.2
image again this weekend but didn't get a chance to try to build
Axiom on it.

These are the replies but I don't understand them (since I haven't
spent the necessary time to reproduce the problem yet).

Do these make sense to you? 
Do you have the same problem?
If you have a clue perhaps I can make a suse stanza to fix it.


There were two responses to your email re. the problem I have with
the axiom installation (see below).

Unfortunately, I do not know lisp so its not clear what should be

Any assistance would be much appreciated.

Thanks very much.


C. Frangos.

> >
> >BOOT>(compile 'foo)
> >cc1: error: /root/axiom/mnt/fedora5/bin/../h: Permission denied
> >

I belive this is the same problem as discussed in the thread starting =

It not easy to decide whom to blame (and which programs should be =
In wh-sandbox I worked around the problem by making sure that for
user compiler::*default-system-p* is set to nil (it _must_ be set
to t during build).

                              Waldek Hebisch


Turning off si::*default-system-p* as Waldek said works, but does so
by copying the header contents into each .c file to be compiled.  One
can also add :system-p nil to the compile-file command.  The real
issue is that apparently the install mechanism has not reset the
system library paths to their installed location.

In particular, when you move the compiled source tree (keeping its
structure intact), the si::*system-directory* and si::*lib-directory*
must be set to their final locations.  There is a routine
si::reset-sys-paths to help with this:

(defun reset-sys-paths (s)
  (declare (string s))
  (setq si::*lib-directory* s)
  (setq si::*system-directory* (si::string-concatenate s "unixport/"))
  (let (nl)
    (dolist (l '("cmpnew/" "gcl-tk/" "lsp/" "xgcl-2/"))
      (push (si::string-concatenate s l) nl))
    (setq si::*load-path* nl))


>(si::reset-sys-paths "/new/location/gcl-install/")
>(si::save-system "foo")

mv foo /new/location/gcl-install/unixport/

GCL's make install is supposed to do this, but if the axiom build is
moving gcl images around by hand, this needs to be invoked at some

Bob Boyer once convinced me that autoloading and other dependence on
runtime files to be found in particular locations was a really bad
idea.  One great thing about GCL, IMHO, is that one can use it as a
completely self-contained stand-alone binary which can be moved around
at will (provided at least, of cource, that one sets
si::*default-system-p* to nil).

Take care,

root <address@hidden> writes:

> Camm,
> GCL seems to have built on Suse 10.2 and the system command works.
> The GCC compiler appears to be in the path. Yet it appears that
> GCL cannot execute it. CC1 seems to be looking in the wrong place
> for the .h files. Do you have any insight into this?
> Tim
> From: "C. Frangos" <address@hidden>
> Subject: Re: Installing axiom on suse linux 10.2
> To: address@hidden
> Date: Wed, 3 Oct 2007 23:00:10 +0200
> Reply-To: address@hidden
> I tried  the instructions and it seems that the )sys command is=20
> working.
> I use this command to delete foo1, and call gcc in order to compile =
one of=20

> C programs located in another directory (see below).
> It seems that gcc is on the path, but I dont recall the linux command =
> explicitly check this.
> Regards,
> C. Frangos.
> (1) -> )sys rm /home/cfrangos/temp/foo1                   =20
> (1) -> )sys gcc -o test1 /home/cfrangos/src/agvs1.c -lm -O3
> (1) ->=20

reply via email to

[Prev in Thread] Current Thread [Next in Thread]