[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] Compile failure on Linux x86-64 (Error 255)

From: Adam Williamson
Subject: [Axiom-developer] Compile failure on Linux x86-64 (Error 255)
Date: Fri, 1 Aug 2008 12:46:44 -0700

Hi, all. I am updating old packages in Mandriva, and I've come to
Axiom. Our current package is for a version from 2005, and doesn't
rebuild cleanly.

I've updated the package to the current Gold release, and it builds
okay (and seems to work, at least as far as I can judge...) on i586.
However, I've had problems on x86-64.

First I ran into the gcl "I am not an object" problem which was
documented on a few lists back in 2007. I worked around this by
replacing the gcl snapshot in Axiom with a bang up to date one from
today (and disabling one Axiom patch that doesn't apply any more). That
gets through that error.

However, now the build fails later on:

44 invoking make in /home/mandrake/rpm/BUILD/axiom/src/boot with parms:
SYS= linux
LSP= /home/mandrake/rpm/BUILD/axiom/lsp
PART= cprogs
SPAD= /home/mandrake/rpm/BUILD/axiom/mnt/linux
SRC= /home/mandrake/rpm/BUILD/axiom/src
INT= /home/mandrake/rpm/BUILD/axiom/int
OBJ= /home/mandrake/rpm/BUILD/axiom/obj
MNT= /home/mandrake/rpm/BUILD/axiom/mnt
make[3]: *** [/home/mandrake/rpm/BUILD/axiom/obj/linux/bin/bootsys]
Error 255 make[3]: Leaving directory
`/home/mandrake/rpm/BUILD/axiom/src/boot' make[2]: *** [bootdir] Error 2
make[2]: Leaving directory `/home/mandrake/rpm/BUILD/axiom/src'
make[1]: *** [srcdir] Error 2
make[1]: Leaving directory `/home/mandrake/rpm/BUILD/axiom'
make: *** [all] Error 2

Does anyone know how this can be fixed? The full build log is here:

but it'll disappear in a few days. Just to note again, the build works
on i586. So this appears to be x86-64 specific in some way.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]