[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] Axiom on Windows

From: Kenneth Evans
Subject: [Axiom-developer] Axiom on Windows
Date: Tue, 01 Feb 2011 14:44:51 -0600
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7


I am new to Axiom and am trying to use it on Windows 7, 64-bit. (I am experienced with Mathematica but have never previously used Axiom.) Most of the bits and pieces to make this work appear to be out there, but are not very well documented or easy to find. Clearly, several people have taken the time to make installers, etc. Surely someone is actually using it successfully on Windows.

I myself have it working to some extent.  This is what I did:


I installed them in the order OpenAxiom, FriCAS, Axiom (not having much information on which of the three to use). They all installed and made desktop shortcuts. The ones for OpenAxiom and Axiom, more or less worked from the shortcuts with the command-line interface. The one for FriCas failed with a socket error ("can't open socket listing file"). They all put their paths in PATH, which could possibly be a problem. I uninstalled FriCAS. The others I installed and reinstalled as I found one did some things right and the other other things right. Currently they are both installed with Axiom first in the PATH.

I got the QT windows version of TeXmacs.

I got it running. It is apparently set up for Axiom. I cloned the axiom plug-in and made it work for OpenAxiom using snippets of information gleaned via the web. So I can now run both as sessions in TeXmacs. Axiom works better for me. I can, in fact, do a lot of what Axiom as a CAS is supposed to do.

The main problem with TeXmacs is that when it is covered by another window, clicking on the title bar causes it to maximize, rather than just coming on top -- very annoying.

The main problem I have right now with the CAS is that I cannot get it to read .axiom.input. I would like to do this to, at a minimum, set my working directory to "My Documents/Axiom" where I expect to keep my .input files. This is what happens (with Axiom in the command-line interface to keep it simple):

1. )cd doesn't work

(1) -> )cd

   >> System error:
   Cannot get the truename of #p"~/".

protected-symbol-warn called with (NIL)
(1) ->

Using ")system ls", I can see that I am in "My Documents, actually c:\Users\evans\Documents. I would guess Axiom didn't do this as it doesn't seem to know it (Axiom) is there. It is probably some kind of windows default.

)cd Axiom doesn't work.  In fact, nothing I have tried works except:

)cd c:/Users/evans/Documents/Axiom

Even after that )cd still doesn't work, but )read <filename-without-path> works.

Before doing that )cd Axiom or ./Axiom didn't work.

Is there some way to get around this? Note that $HOME is defined as c:\Users\evans\Documents. You would think it might try $HOME if ~ fails.

2. It does not read .axiom.input. I have tried putting it where it should be (c:\Users\evans) in "My Documents" and in other places. Does anyone know how to make it read .axiom.input.

These are some things from the environment that might be applicable:

OPENAXIOM=C:/Program Files (x86)/OpenAxiom/lib/open-axiom/i686-pc-mingw32/1.3.0

Thanks in advance for any help.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]