[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Axiom-developer] axiom integrate() return wrong result

From: daly
Subject: Re: [Axiom-developer] axiom integrate() return wrong result
Date: Sat, 29 Nov 2014 06:54:43 -0600

Thank you for taking the time to generate a bug report.

>I'm exploring the power of integrate() in Axiom, and find that
>draw(b, x=0..4)
>draw(f, x=0..4)
>give me inconsistent result.

Yes, Axiom did give an "inconsistent result", which is most likely
a "wrong" result as well.

>If change to say f:=1/(x^4+1), then I get consistent result.

Actually that looks wrong also. Click on the graph to bring up
the control panel, click on "units on", and you'll find that
the curves are different. The integrate/differentiate is failing.

>Also tested latest code (2014-11-28) in github(git clone 
>bug 7251, 7147, 7085/15, 7084/293 may be related to this bug?
>Note that strictly speaking, integrate(1/(x^4+1),x) also returns an 
>incorrect result (correct only when understand it as a complex 
>multi-value function).

I don't know if these are related (the integration code is not
simple and chasing bugs is time-consuming). 

>One more note: I have tried FriCAS (also the latest version), it give me 
>the correct integration result.

I tried FriCAS (2013-04-06 on MAC OS X). 

I found that 

draw(b, x=0..4)

fails with the message:

  Compiling function %O with type DoubleFloat -> DoubleFloat

  >> System error:
  Too large to be represented as a SINGLE-FLOAT

Also, the graphs show that the result is wrong when you turn
"units on".

When I get near my office I will try the test in Maple and MMA.

Thanks for the bug report.

Can you send your full name to "address@hidden" so I
can list you in the credits?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]