[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Axiom-developer] compile errors

From: Lawrence Bottorff
Subject: Re: [Axiom-developer] compile errors
Date: Fri, 9 Oct 2015 21:58:31 +0000

After crashing my computer a few times (Ubuntu 15.04), I finally got this:

Unrecoverable error: invocation history stack overflow.
Aborted (core dumped)
Makefile:175: recipe for target '/home/hercynian/gitstuff/axiom/obj/ubuntu/bin/depsys' failed
make[3]: *** [/home/hercynian/gitstuff/axiom/obj/ubuntu/bin/depsys] Error 134
rm /home/hercynian/gitstuff/axiom/int/interp/nocompil.lisp /home/hercynian/gitstuff/axiom/int/interp/sys-pkg.lisp /home/hercynian/gitstuff/axiom/int/interp/util.lisp /home/hercynian/gitstuff/axiom/int/interp/parsing.lisp
make[3]: Leaving directory '/home/hercynian/gitstuff/axiom/src/interp'
Makefile:79: recipe for target 'interpdir' failed
make[2]: *** [interpdir] Error 2
make[2]: Leaving directory '/home/hercynian/gitstuff/axiom/src'
Makefile.ubuntu:148: recipe for target 'srcdir' failed
make[1]: *** [srcdir] Error 2
make[1]: Leaving directory '/home/hercynian/gitstuff/axiom'
Makefile:134: recipe for target 'all' failed
make: *** [all] Error 2

Please advise.


On Fri, Oct 9, 2015 at 6:36 AM, <address@hidden> wrote:
I built a new Ubuntu 10.04 machine from scratch.
I installed the packages listed on the downloads web page on
I did the git clone and subsequent instructions above.
My compile worked.

Perhaps your GCC is downlevel?


>Sorry - just tried that on my work computer (Ubuntu 14.04), and same errors.
>On Fri, Oct 9, 2015 at 10:18 AM, Alasdair McAndrew <address@hidden> wrote:
>> Thanks!  Will give it my best shot when I get home.
>> cheers,
>> Alasdair
>> On Fri, Oct 9, 2015 at 10:12 AM, <address@hidden> wrote:
>>> git clone git://
>>> cd axiom
>>> export AXIOM=`pwd`/mnt/ubuntu
>>> export PATH=$AXIOM/bin:$PATH
>>> make

Axiom-developer mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]