|Subject:||Re: [PATCH] overquoting in implementation of %code and %defines|
|Date:||Mon, 15 Jan 2007 09:13:00 +0100|
|User-agent:||Thunderbird 22.214.171.124 (Macintosh/20061207)|
Please don't. m4_define_default is preferable in my opinion. I really see no reason to extend b4_get_percent_define, but I will just to settle this.
Note that the reason I don't like the current implementation is because I'm against "magic" macro names.
So another way to break the tie and not add the second parameter would be to change the default macro name to "b4_get_percent_define(NAME)" and have a "b4_define_default(NAME, FOO)" macro that defines this special-named macro.
|[Prev in Thread]||Current Thread||[Next in Thread]|