[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Joel E. Denny
Sat, 29 Sep 2007 19:11:20 -0400 (EDT)
The XML output has two different elements named "reductions". One reports
reduce actions in the sense of productions performed by a bottom-up
parser. The other reports useless/unused symbols and rules that are found
by the grammar reductions of reduce.c.
Perhaps we can choose a better name for the latter case.
"grammar_reductions", "redundancies", any other suggestions? Or perhaps
the "useless" and "unused" elements don't need to be grouped together
inside a parent element. There's only one of each anyway. Here's an
example from Wojciech's web page:
What do you think?
Joel E. Denny <=