[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] master: variables: rename namespace as api.namespace.

From: Joel E. Denny
Subject: Re: [PATCH] master: variables: rename namespace as api.namespace.
Date: Thu, 16 Jul 2009 05:17:31 -0400 (EDT)
User-agent: Alpine 1.00 (DEB 882 2007-12-20)

On Wed, 24 Jun 2009, Akim Demaille wrote:

> Discussed in
>       * data/bison.m4 (b4_percent_define_copy_, b4_percent_define_copy):
>       New.
>       (b4_percent_define_use): New.
>       Use it where applicable.
>       * data/c++.m4: Replace uses of the variable "namespace" by
>       "api.namespace".
>       Default the latter to the former.

You've handled this rename differently than I handled the rename of 
api.push_pull and lr.keep_unreachable_states to contain dashes instead of 
underscores.  I'm not convinced my approach is better, but we ought to 
consider whether just one of our approaches is sufficient for all these 

In muscle_percent_define_insert, I simply implemented the old variables as 
aliases for the new variables.  A disadvantage is that error messages for 
the old variables are reported for the new variables instead.  That might 
confuse the user a bit, but the names are fairly similar and we usually 
report line and column numbers in our error messages.

Your implementation is slightly more complex.  Another disadvantage of 
yours is that, if both the old and new name is defined, the old one is 
reported as unused with no indication of why.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]