|I agree that the first one is more like the usual function definition.|
Like in UI design’s “principle of least astonishment”, the more familiar a thing looks, the better.
Thinking about lambdas once more I had an idea of a syntax for
declaring local variables in
the lambda. In order to bring lambdas and proper functions closer
together rather than separating
them more than necessary, we could use the same syntax as in
proper defined functions: a list
of variable names separated by semicolons. A lambda with body ⍺+⍵ and
local variables C, D,
and E would then be declared as:
One could also think of
But the first looks more appealing to me. Any opinions?