[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-AUCTeX] Re: rel-0-9-1; installation problem

From: Jeff Flowers
Subject: [Bug-AUCTeX] Re: rel-0-9-1; installation problem
Date: Fri, 08 Apr 2005 18:46:15 +0100
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050319

David Kastrup wrote:
[Keeping bug-auctex copied]
sorry I was getting bounces from that

[snip]  Just for the record: what is the output of
M-: preview-icondir RET


which I guess is wrong!!

Serves me right.  I should have also asked just where preview-latex.el
is installed.  The most likely explanation would seem that you
_manually_ copied it to the preview subdirectory, while the
installation procedure intended to place it in the site-lisp
directory.  Since the search paths are then created _relatively_ to
the preview-latex.el file, stuff breaks.

Now in ancient times (like a month ago or so), the installation
instructions demanded that you place the preview subdirectory into
your search path or let this automatically happen, then copy
preview-latex.el somewhere where it can be found.  I can't exclude the
possibility that there were oversights in updating the installation
instructions.  The file preview-latex.el you quoted definitely is a
new-style file, so it really is likely that you manually installed it
in the wrong place.

If this guess is correct, can you remember what made you do so?
Advice on some web page, previous printouts from the manual, or
something that still is left in the current instructions?  Or was this
a "lucky guess" after the normal installation broke, and you tried
fixing it?  This would really be important to reconstruct: even in
case it can be called a "user error", we want to avoid opportunities
for them as much as possible, too.

You are correct. I manually installed it in the wrong place. I saw that install was trying to put files in the preview subdirectory, so I guessed wrongly that preview-latex.el should go with them and put it there. I have manually moved it to site-lisp now, and as if by magic the icons appeared.

[snip analysis of config.log]

The rest looks sane.  I'll append a patch that is supposed to deal
with everything.  You have to run patch -p0 with an input redirection
from this mail (or just the patch section) in the preview directory,
then run autoconf, and restart ./configure with the above options.
Let us see whether you fare better this time.  The packagelispdir
stuff I can't deal with sensibly right now since I am working on
replacing it with something saner, and since it worked before, there
is not much to be gained by getting the old stuff to work in
exceptional circumstances.  However, this did the right thing with
other test scenarios, so it might just work.

I'll remove preview-latex and try the patched install soon



reply via email to

[Prev in Thread] Current Thread [Next in Thread]