[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-AUCTeX] Re: No preview images found anywhere

From: David Kastrup
Subject: [Bug-AUCTeX] Re: No preview images found anywhere
Date: Fri, 17 Jun 2005 16:23:27 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

"Stephen Harris" <address@hidden> writes:

> I originally posted this to the bug-auctex, the default email
> address using preview-latex and M-x preview-report-bug RET
> but I noticed there was very little traffic recorded at the
> archives.

That's because the list is young, not because it would be inaccurate
to do so.  The Sourceforge list is one-way and gated to bug-auctex,
and subscriptions are no longer taken.  So bug-auctex is the correct
list to use, even though the documentation in already released
versions has not yet had opportunity to reflect this change.

> Remember to cover the basics.  Including a minimal LaTeX example
> file exhibiting the problem might help.
> I used circ.tex trying to generate a preview image. Preview
> said it contained no images. I also tried this short file
> which returned the same error of no images. I tried all
> the options under the Preview menu. I read about
> Gadzillions in the FAQ, which is happening here, but
> there must be some way to generate a preview or
> it isn't a preview. I can "view" the circ.ps file or
> circ.pdf by calling gswin32 from inside Xemacs
> with C-c C-c view RET, then type in gsview and
> the name of the file RET and that opens GS.

If you get 103 images, this basically would prove that the LaTeX setup
on your system is working correctly (or you would not get hundreds of
images in the produced file).

> These are logs and messages generated when using circ.tex
> Running `LaTeX' on `circ' with ``latex  "\nonstopmode\input{circ.tex}"''
> This is e-TeX, Version 3.141592-2.2 (MiKTeX 2.4)
> entering extended mode
> LaTeX2e <2003/12/01>
> Babel <v3.8g> and hyphenation patterns for english, french, german, ngerman, 
> du
> mylang, nohyphenation, loaded.
> (circ.tex (C:\Miktex\texmf\tex\latex\base\article.cls
> Document Class: article 2004/02/16 v1.4f Standard LaTeX document class
> (C:\Miktex\texmf\tex\latex\base\size10.clo))
> (C:\Miktex\texmf\tex\generic\babel\babel.sty
> (C:\Miktex\texmf\tex\generic\babel\germanb.ldf
> (C:\Miktex\texmf\tex\generic\babel\babel.def)))
> (C:\Miktex\texmf\tex\latex\base\fontenc.sty
> (C:\Miktex\texmf\tex\latex\base\t1enc.def))
> (C:\Miktex\texmf\tex\latex\base\inputenc.sty
> (C:\Miktex\texmf\tex\latex\base\latin1.def))
> (C:\Miktex\texmf\tex\latex\preview\previewsty
> (C:\Miktex\texmf\tex\latex\preview\prshowlabels.def)) (circ.aux)
> (C:\Miktex\texmf\tex\latex\base\t1cmtt.fd)
> Underfull \hbox (badness 1028) in paragraph at lines 53--55
> \T1/cmr/m/n/10 heiÿt, ent-we-der durch-ge-hend stei-gend oder
> [1] [2] [3]
> Underfull \vbox (badness 10000) has occurred while \output is active [4]
> [5] (circ.aux) )
> (see the transcript file for additional information)
> Output written on circ.dvi (5 pages, 36392 bytes).
> Transcript written on circ.log.

Uh, stop.  The above is the log file output from a normal LaTeX run.
It is not relevant for preview-latex.

> Output of C-c C-l
> LaTeX finished at Fri Jun 17 03:42:43
> (see the transcript file for additional information)
> Output written on circ.dvi (103 pages, 41988 bytes).
> Transcript written on circ.log.
> Preview-LaTeX exited as expected with code 1 at Fri Jun 17 04:01:06
> LaTeX: LaTeX found no preview images

This is the output of preview-latex.  Unfortunately, there is too
little in this excerpt to see the problem.  Can you post the contents
from the start of this buffer up to the first few diagnostics from
preview-latex (something like ! Preview: snippet 4 started)?

> (setq
>  AUC-TeX-version "11.55"
>  LaTeX-command-style '(("" "%(PDF)%(latex) %S%(PDFout)"))
>  preview-image-type 'pnm

You probably customized 'pnm yourself.  While the output from
GhostScript suggests that at least GhostScript supports the image
format, png should be preferable.

It might be a possibility that your XEmacs does not support either png
or pnm images because it would need proper libraries.  While there
should be an error message in this case, we had reports in the past
where this did not happen.

Please type
M-: (preview-supports-image-type 'png) RET

to your system.  If this displays `nil', there is a problem with the
PNG support or libraries from XEmacs.  Similarly for
M-: (preview-supports-image-type 'pnm) RET

If any of those return "nil", it would be important for us to know
since you are supposed to get an error message in this case.

David Kastrup, Kriemhildstr. 15, 44793 Bochum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]