[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-AUCTeX] 11.82; removing AUCTeX

From: Les Saper
Subject: [Bug-AUCTeX] 11.82; removing AUCTeX
Date: Wed, 19 Apr 2006 17:33:07 -0400

I would like to remove or disable a site-installed AUCTeX.  I 
tried this two ways, as indicated below.  The first way
(recommended in the documentation) resulted in an 
error; I include the backtrace.   The second way works but is too
cumbersome for general use.  I also include a note that may
suggest the problem.

(Note that in November I reported a somewhat different bug in 
11.81 regarding removing auctex; that bug I understand was fixed.  
The current error message is different.) 

1) According to the manual removing AUCTeX can be done by including the line 

  (unload-feature 'tex-site)

in my ~/.emacs file.  When I do this I am informed that an error occured
while loading .emacs:

  An error has occurred while loading `/home/faculty/saper/.emacs':

  error: "Loaded libraries 
(\"/usr/share/emacs/site-lisp/site-start.d/auctex-init.el\") depend on tex-site"

The full backtrace is an follows:

Debugger entered--Lisp error: (error "Loaded libraries 
(\"/usr/share/emacs/site-lisp/site-start.d/auctex-init.el\") depend on 
  signal(error ("Loaded libraries 
(\"/usr/share/emacs/site-lisp/site-start.d/auctex-init.el\") depend on 
  error("Loaded libraries %s depend on %s" 
"(\"/usr/share/emacs/site-lisp/site-start.d/auctex-init.el\")" "tex-site")
  eval-buffer(#<buffer  *load*> nil "~/.emacs" nil t)
  load-with-code-conversion("/home/faculty/saper/.emacs" "~/.emacs" t t)
  load("~/.emacs" t t)
"??    ?=???Q?5      ?=?'????#?#??5??5       
 ????#))?" [init-file-user system-type user-init-file-1 user-init-file source 
alt ms-dos "~" "/_emacs" windows-nt directory-files nil 
"^\\.emacs\\(\\.elc?\\)?$" "~/.emacs" "~/_emacs" vax-vms "sys$login:.emacs" 
"/.emacs" t load file-name-extension "elc" file-name-sans-extension ".el" 
file-exists-p file-newer-than-file-p message "Warning: %s is newer than %s" 
sit-for 1 "default" inhibit-default-init inhibit-startup-message] 5]()

2) I also tried to start emacs with `emacs -q -no-site-file' as recommended in
the FAQ.  I then evaluated (load "auctex.el" nil t t) in order to load
AUCTeX.  I then evaluated (unload-feature 'tex-site) to remove AUCTeX.
This works but obviously I cannot do this every time, and in any
case it precludes my having a .emacs file.

3) I notice in our installation that  


includes both  auctex-init.el and  auctex.el .  The
auctex-init.el file has contents:

; Autoactivation of AUCTeX
; Created for emacs-auctex-11.82-1.fc4.noarch.rpm
(require 'tex-site)

This file seems to be causing the problem.

I would appreciate any suggestions you have.

- Les Saper

Leslie Saper                    e-mail: address@hidden
Department of Mathematics       phone: 919-660-2843
Duke University                 Fax: 919-660-2821
Box 90320
Durham, NC   27708-0320

Emacs  : GNU Emacs 21.4.1 (i386-redhat-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2005-05-18 on decompose.build.redhat.com
Package: 11.82

current state:
 AUCTeX-date "2005-12-17"
 window-system 'x
 LaTeX-version "2e"
 TeX-style-path '("style" "auto"
                  "/usr/share/emacs/site-lisp/auctex/style" "/var/auctex")
 TeX-auto-save nil
 TeX-parse-self nil
 TeX-master t
 TeX-command-list '(("TeX" "%(PDF)%(tex) %S%(PDFout) \"%(mode)\\input %t\""
                     TeX-run-TeX nil
                     (plain-tex-mode ams-tex-mode texinfo-mode) :help
                     "Run plain TeX")
                    ("LaTeX" "%l \"%(mode)\\input{%t}\"" TeX-run-TeX nil
                     (latex-mode doctex-mode) :help "Run LaTeX")
                    ("Makeinfo" "makeinfo %t" TeX-run-compile nil
                     (texinfo-mode) :help "Run Makeinfo with Info output")
                    ("Makeinfo HTML" "makeinfo --html %t" TeX-run-compile nil
                     (texinfo-mode) :help "Run Makeinfo with HTML output")
                    ("AmSTeX" "%(PDF)amstex %S%(PDFout) \"%(mode)\\input %t\""
                     TeX-run-TeX nil (ams-tex-mode) :help "Run AMSTeX")
                    ("ConTeXt" "texexec --once --texutil %(execopts)%t"
                     TeX-run-TeX nil (context-mode) :help "Run ConTeXt once")
                    ("ConTeXt Full" "texexec %(execopts)%t" TeX-run-TeX nil
                     (context-mode) :help "Run ConTeXt until completion")
                    ("ConTeXt Clean" "texutil --purgeall" TeX-run-interactive
                     nil (context-mode) :help "Clean temporary ConTeXt files")
                    ("BibTeX" "bibtex %s" TeX-run-BibTeX nil t :help
                     "Run BibTeX")
                    ("View" "%V" TeX-run-discard t t :help "Run Viewer")
                    ("Print" "%p" TeX-run-command t t :help "Print the file")
                    ("Queue" "%q" TeX-run-background nil t :help
                     "View the printer queue" :visible TeX-queue-command)
                    ("File" "%(o?)dvips %d -o %f " TeX-run-command t t :help
                     "Generate PostScript file")
                    ("Index" "makeindex %s" TeX-run-command nil t :help
                     "Create index file")
                    ("Check" "lacheck %s" TeX-run-compile nil (latex-mode)
                     :help "Check LaTeX file for correctness")
                    ("Spell" "<ignored>" TeX-run-ispell-on-document nil t
                     :help "Spell-check the document")
                    ("Other" "" TeX-run-command t t :help
                     "Run an arbitrary command")

reply via email to

[Prev in Thread] Current Thread [Next in Thread]