[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-AUCTeX] 11.82; removing AUCTeX

From: David Kastrup
Subject: Re: [Bug-AUCTeX] 11.82; removing AUCTeX
Date: Thu, 20 Apr 2006 01:05:23 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

Les Saper <address@hidden> writes:

> I would like to remove or disable a site-installed AUCTeX.  I 
> tried this two ways, as indicated below.  The first way
> (recommended in the documentation) resulted in an 
> error; I include the backtrace.   The second way works but is too
> cumbersome for general use.  I also include a note that may
> suggest the problem.
> (Note that in November I reported a somewhat different bug in 
> 11.81 regarding removing auctex; that bug I understand was fixed.  
> The current error message is different.) 
> 1) According to the manual removing AUCTeX can be done by including the line 
>   (unload-feature 'tex-site)
> in my ~/.emacs file.  When I do this I am informed that an error occured
> while loading .emacs:
>   An error has occurred while loading `/home/faculty/saper/.emacs':
>   error: "Loaded libraries
>   (\"/usr/share/emacs/site-lisp/site-start.d/auctex-init.el\")
>   depend on tex-site"

Well, the obvious solution then would be (unload-feature 'auctex-init)
or something like that.  Not sure whether this can be made to work,

> 2) I also tried to start emacs with `emacs -q -no-site-file' as
> recommended in the FAQ.  I then evaluated (load "auctex.el" nil t t)
> in order to load AUCTeX.  I then evaluated (unload-feature
> 'tex-site) to remove AUCTeX.  This works but obviously I cannot do
> this every time, and in any case it precludes my having a .emacs
> file.
> 3) I notice in our installation that  
> /usr/share/emacs/site-lisp/site-start.d
> includes both  auctex-init.el and  auctex.el .  The
> auctex-init.el file has contents:
> ; Autoactivation of AUCTeX
> ; Created for emacs-auctex-11.82-1.fc4.noarch.rpm
> (require 'tex-site)
> This file seems to be causing the problem.
> I would appreciate any suggestions you have.

Deleting the auctex-init.el file and filing a bug report to Fedora
would seem like the appropriate fix.  Two files in site-start.d for
AUCTeX seem overkill.

Anyway, the Fedora packaging is lacking preview-latex.  I'd recommend
that you get the most recent SuSE Source RPM from the AUCTeX download
site and do an rpmbuild --rebuild on it: this has been reported to
produce a working RPM for Fedora, including preview-latex.

David Kastrup, Kriemhildstr. 15, 44793 Bochum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]