[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-AUCTeX] make not found

From: David Kastrup
Subject: Re: [Bug-AUCTeX] make not found
Date: Wed, 06 Sep 2006 23:08:16 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

"Sigve Berge Hofland" <address@hidden> writes:

>> > I am trying to configure auctex-11.83 but I get this error message:
>> > checking for make... no
>> > configure: error: make not found, aborting!
>> What operating system are you using?  You need to have a make utility
>> installed and in your PATH: how this is done very much depends on the
>> system in question.
> Mac OS X 10.4.7 PPC. No, I have not installed 'make'. It wasn't on
> the list of prerequisites, so I didn't know I had to. Today I tried
> to install GNU-make, but I wasn't able to configure that either due
> to: "configure: error: no acceptable C compiler found in $PATH". I
> then tried to download GNU GCC, but there GNU-make was listed as a
> prerequisite. I would be very grateful for a useful hint on how to
> get out of this circular problem.

Please keep the list copied and don't reply to me in private.  I don't
have a Mac and so can't be really useful.  Also it is important for
all the developers to figure out how to amend the manuals in order to
help people better in future.  That is not possible if you reply to me
in private.

Anyway: This is a bootstrapping problem: you need some compiler to get
out of your bland compiler-less state.  I think there is something
called "Fink" containing a large bunch of software; that might get you
a useful development system.

However, if you are not into compiling things yourself, there is a
precompiled Emacs including AUCTeX available that is called Aquamacs.
There is also Yaced (which is closer to the original Emacs), but that
has not been updated for a year or so.

David Kastrup, Kriemhildstr. 15, 44793 Bochum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]