[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-AUCTeX] 11.83; problem with emacs' auto-fill and auctex's foldi

From: Patrick Drechsler
Subject: Re: [Bug-AUCTeX] 11.83; problem with emacs' auto-fill and auctex's folding mode in noweb mode
Date: Tue, 10 Oct 2006 21:46:18 +0200
User-agent: Thunderbird (X11/20060922)


I'll reply to both of your messages:

Ralf Angeli wrote: * Patrick Drechsler (2006-10-08) writes:
Which version of noweb-mode.el are you using in case it is?

I'm using the noweb-mode included in the Emacs-CVS version I'm using (`M-x noweb-mode-version'):

There is no noweb-mode.el included in CVS Emacs.

Of course your statement is correct. I a using the noweb-mode version
included in ESS 2.3.3. But I have also tried versions of noweb-mode.el going back a few version (at least a year). This did not pose a problem before AUCTeX 11.83.

Ralf Angeli wrote:
* Ralf Angeli (2006-10-10) writes:

* Patrick Drechsler (2006-10-08) writes:

Are there any tests I can perform or should I post this question to the ESS mailing list?
You could put (setq debug-on-error t) as the first line into your init file, restart Emacs and see if you get a backtrace during startup or when loading a LaTeX/noweb file.

You could also do `M-x toggle-debug-on-quit RET', type `M-q' to provoke a loop during filling, type `C-g' for quitting and post the backtrace you obtain from that.

Dear Ralf,

thank you very much for your patience.

Putting (setq debug-on-error t) as the first line of my init.el file did
not show any output either. But invoking `M-x toggle-debug-on-quit RET'
and then typing `C-g' produced an output:

Debugger entered--Lisp error: (quit)
  line-move-1(1 nil nil)
  line-move(1 nil nil nil)
  (while (re-search-forward "^\\(@\\( \\|$\\|\\(
%def\\)\\)\\|<<\\(.*\\)>>=\\)" nil t) (goto-char (match-beginning 0))
(if (not ...) (setq chunk-list ...) (progn ... ... ...)) (next-line 1))
  (let ((chunk-list ...)) (while (re-search-forward "^\\(@\\( \\|$\\|\\(
%def\\)\\)\\|<<\\(.*\\)>>=\\)" nil t) (goto-char ...) (if ... ... ...)
(next-line 1)) (setq chunk-list (cons ... chunk-list)) (setq
noweb-chunk-vector (vconcat ...)))
  (save-excursion (goto-char (point-min)) (let (...) (while ... ... ...
...) (setq chunk-list ...) (setq noweb-chunk-vector ...)))

Furthermore I have tried if the following code chunk influences things:

;; auto-fill-mode for noweb files:
(add-hook 'noweb-mode-hook (lambda ()

;; set column fill length:
(defun pd-noweb-mode-hook ()
  (setq fill-column 79)) ; where auto-fill should wrap
(add-hook 'noweb-mode-hook 'pd-noweb-mode-hook)

It does not make a difference if I include or exclude the above. The back trace is identical to the above mentioned back trace.

I have also double checked that the fill-column length is the same for LaTeX and ESS (both are set to 79 characters):

(defun pd-latex-mode-hook ()
  "LaTeX setup."
  (setq fill-column 79))
(add-hook 'LaTeX-mode-hook 'pd-latex-mode-hook)

Something I have forgotten to mention in my original post is the fact that the minimal example does not end in *.tex but in *.Rnw.

This seems to be the problem.

Everything works as expected for *.tex files. As soon it is renamed to *.Rnw one receives the back trace mentioned above.

So this seems to be a noweb-mode problem. BUT this worked with previous versions of AUCTeX (ie 11.82). And as I have mentioned above I have tested it with older ESS versions.

Do you have any further ideas what I should try or should I move the discussion somewhere else?

Should I downgrade my AUCTeX version to see if this is reproducible? Or does the back trace provide enough information to eliminate the error?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]