[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-AUCTeX] Re: auctex 11.85 configure hangs

From: Rodney Sparapani
Subject: [Bug-AUCTeX] Re: auctex 11.85 configure hangs
Date: Fri, 13 Jun 2008 10:45:58 -0500
User-agent: Thunderbird (X11/20080505)

David Kastrup wrote:

Well, the construct loops while there is a $ in "$tmpdir".  It breaks
out of the loop when there isn't.  That's quite straightforward.  The
sed command replaces the three characters \ ` " with \ followed by the
characters.  That gives an additional level of quoting which the eval
(which is there for expanding $ until none is left) then strips again.

It would be interesting to see what happens on the system where it
fails.  One thing that might help is writing
instead, doubling the initial \ in case sed misinterprets the range (I
am not sure why we have "-" instead of just ", probably to stop syntax
highlighting from going complete bonkers).

Hi David:

Unfortunately, that doesn't help. And, I tried XPG4 sed and GNU sed 4.1.4. I also tried different CONFIG_SHELL settings: XPG4 Bourne, zsh and bash. No matter what I do it inf. loops. Can someone send me there Makefile? Maybe I can get an idea from that. Hopefully, from some one who uses xemacs, but maybe that is not critical.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]