[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-AUCTeX] Apparent overlap in printing command configuration

From: Reuben Thomas
Subject: [Bug-AUCTeX] Apparent overlap in printing command configuration
Date: Sat, 17 Apr 2010 23:31:42 +0100


I'm using AuCTeX 11.85 as shipped with the upcoming Ubuntu Lucid, so
apologies if I'm out of date.

I have a bundle of overlapping questions, effectively:

1. I was trying to print PDF files, having chosen to use PDFTeX minor
mode. Should I expect the printer command to have been adjusted
automatically? When I tried to print with C-c C-c P(rint), I got the
command dvips -f foo | lpr, which would of course have failed to find
a DVI file.

2. I then tried to find out what to customize, and lit on
TeX-printer-command, but customizing this didn't change the command I
was offered.

3. I then found TeX-printer-list, which contained the command I was
being offered.

The manual doesn't mention either TeX-printer-command or
TeX-printer-list AFAICS, so I am puzzled: what is TeX-printer-command
for, and what is TeX-printer-list for? Is there overlap or redundancy
to fix here?

I see in the ChangeLog for 11.86 "An easy way to switch between TeX
engines (PDFTeX, LuaTeX, XeTeX, Omega) was added.", so perhaps I
should install 11.86 and try again? (It would be nice if AuCTeX were
available to package.el, is that in the works?)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]