[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-AUCTeX] Apologies: solved (was: 4.33; reftex-toc does not work, for

From: Uwe Brauer
Subject: [Bug-AUCTeX] Apologies: solved (was: 4.33; reftex-toc does not work, for certain values of kill-buffer-hook)
Date: Thu, 01 Jul 2010 10:47:51 +0200
User-agent: Gnus/5.110011 (No Gnus v0.11) XEmacs/21.4.21 (linux)

>>>>> On Wed, 30 Jun 2010 22:25:29 +0200, Ralf Angeli <address@hidden> wrote:

   > * Uwe Brauer (2010-06-28) writes:
   >> I confirm that in 4.21/4.22 this problem does not occur!

   > I tried it now with compiling the Lisp files of RefTeX 4.33 with XEmacs,
   > firing up XEmacs, adding the directory with the Lisp files to load-path,
   > requiring `reftex', loading vc-ensure-checkin.el, loading circ.tex,
   > turning on RefTeX and bringing up the table of contents.  All of that
   > worked fine, i.e. I still cannot reproduce the problem you were
   > describing.

   > Here are the commands I used:

   > make EMACS=/usr/bin/xemacs
   > xemacs -q -no-site-file
   > M-: (add-to-list 'load-path "/path/to/lisp/files") <RET>
   > M-: (require 'reftex) <RET>
   > C-x C-f circ.tex <RET>
   > M-: (turn-on-reftex) <RET>
   > C-c =
you are right. :'(

I should have checked more carefully indeed in my init file
there was ancient stuff of the form 

 (autoload 'reftex-mode               "reftex" "RefTeX Minor Mode" t)
 (autoload 'turn-on-reftex            "reftex" "RefTeX Minor Mode" nil)
 (autoload 'reftex-add-to-label-alist "reftex" "RefTeX Minor Mode" nil)

(add-hook 'LaTeX-mode-hook 'turn-on-reftex)   ; with AUCTeX LaTeX mode

which of course fails, since turn-on-reftex is now defined
in reftex-base.

So simply adding 
(require 'reftex)

Did the job. :-D


reply via email to

[Prev in Thread] Current Thread [Next in Thread]