[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-AUCTeX] TAB key does not let me insert a non-existing label

From: Scot Becker
Subject: Re: [Bug-AUCTeX] TAB key does not let me insert a non-existing label
Date: Tue, 14 Sep 2010 12:10:21 +0100


Thanks for the reply.  I tried it now on both Emacs 23 and 24, with
both my full setup and with emacs -Q, with identical results.  When
you tried it, did you test it by typing a citation key that is not in
your database?  It works fine if I only use keys in my database, but
not if I type one that isn't there.  (This is presumably designed for
the case where you want to cite something that isn't in your database
yet.  In my case I have to go through an external database [Zotero]
and export to BibTeX, which I don't want to stop and do when I
discover I need to cite something new.)

Here's what I did to test Emacs 23, (this time with the inbuilt RefTeX):

$ /usr/bin/emacs -Q

Then I evaluate:
(setq reftex-default-bibliography

Then I do (in the scratch buffer, for example):

M-x reftex-citation RET try RET

(which gives me a list of items matching 'try'.  But I don't have the
entry I want in my list, so I do:)

TAB mykey2000 RET

I get only 'mykey2000' in the echo window.  No citation command
inserted into the buffer.

I get the same results in a proper LaTeX buffer, visiting a file.  If
I want to insert references which actually exist in my database, I
have no problems.

> A common workaround is to copy the text generated by `reftex-report-bug'
> into a message to be sent through a configured mail client.

Somehow an appropriately broken mail setup throws up an error even
before any text is generated by `reftex-report-bug'.  I can remove the
setup if it would help us debug, but the above recipe is with emacs
-Q, so I guess it's not needed.

Tried on:
GNU Emacs (i486-pc-linux-gnu, GTK+ Version 2.18.0) of
2009-09-27 on palmer, modified by Debian

reply via email to

[Prev in Thread] Current Thread [Next in Thread]